AI4D Predict the Global Spread of COVID-19
$5,000 USD
The accuracy of your models will be assessed on future data
721 data scientists enrolled, 33 on the leaderboard
13 March—19 April
Ends in 10 days
Error submitting predictions.
published 23 Mar 2020, 10:56

I am getting this error when I try to submit the sampleSubmission.csv. "Missing entries for IDs Afghanistan X 3/13/20, Afghanistan X 3/14/20, Afghanistan X 3/15/20, Afghanistan X 3/16/20, Afghanistan X 3/17/20 and more"

Any idea on what I'm doing wrong?

Check if you are not submitting "Afghanistan X 03/13/20" rather then "Afghanistan X 3/13/20" (month with "0").

I am also getting the same error. Did remove leading zeroes and still getting the error.

check also if the file has 19647 lines and the target is formatted with a int value

@rdeggau I have 19646 lines of data plus the header making it 19647 and the target variable is an int value.

Hi. I need your help too for this submission error : "Missing entries for IDs Bahamas (the) X 3/13/20, Bahamas (the) X 3/14/20, Bahamas (the) X 3/15/20, Bahamas (the) X 3/16/20, Bahamas (the) X 3/17/20 and more"

I have in my file "The Bahamas X 3/13/20" in place of "Bahamas (the) X 3/13/20"

Did you see the changes in the original Covid-19-Data-Prep.ipynb? The Excel file with all Countries?

# # Adding All Countries

# To avoid changing the submission format, Zindi are now using a set list of countries. This section will be updated as new Countries/Regions are added to the JHU data, to try and maintain a consistent mapping.

# In[ ]:

# Download a list of countries from the UN

get_ipython().system('curl -o EF.xlsx https://untermportal.un.org/unterm/country/downloadfile?targetLanguage=fr')

# In[ ]:

countries = pd.read_excel('EF.xlsx')[:193]

countries.head(2)

And some lines after: deaths.loc[deaths['Country/Region'] == 'Bahamas, The', 'Territory'] = 'Bahamas (the)'

Thanks. I will check and let you know if it work.

Take a look in the new notebook with changes in Bahamas and another locations

i did it :)! Big thanks for your help, you are amazing!

What else could be the issue for me , i have removed the leading zeros , all target values are of int64 , i have 19646 rows... i don't understand...

if you want you can send me the file. I will try to analyze: rdeggau at gmail.com

I just found the issue , for some reason i forgot to add 'index = False' when creating the csv... silly me :) , it helps to view the csv before submitting it... your offer prompted me to view it, Thanks man...

Thanks for this rdeggau. Ran into the same problem and didn't pay attention to the error message.

removed 0 before months, but I still get "Missing entries for IDs Afghanistan X 4/1/20, Albania X 4/1/20, Algeria X 4/1/20, Andorra X 4/1/20, Angola X 4/1/20 and more". what is going wrong? @rdeggau

Hi cezny. Did you read the new rules for dates in the submission files? https://zindi.africa/competitions/predict-the-global-spread-of-covid-19/discussions/1051

I just find out that removing leading 0s on months was not enough, it looks like we need also to remove them on days data.