Sea Turtle Rescue: Error Detection Challenge
Cash and prizes worth $1,950 USD
Help Local Ocean Conservation clean their sea turtle rescues database
30 November 2018–28 April 2019 23:59
301 data scientists enrolled, 53 on the leaderboard
Submission File Error :
published 1 Apr 2019, 09:31
edited 2 minutes later

Hi guys, I'm running into an issue while submiting my results.

"Missing entries for IDs 2011_RE_0439 x Researcher, 2011_RE_1047 x Tag_2, 2011_RE_1149 x ForagingGround and more" is the error outputed while making a submission.

I have confirmed atleast thrice for the entries presence. For example, df_submission.iloc[10951][0] == '2011_RE_0439 x Researcher' --> True. I believe many others might have run into the same problem as only 20% of the participants have made a proper submission till date.

Just to be clear, the output of df_submission.iloc[22791] (for me) is

ID       2011_RE_0915 x Weight_Kg
error    0.19782
Name: 22791, dtype: object

Did anyone run into this problem? I can't seem to find a solution.

Note : I tried to force utf-8 encoding, it didn't seem to work as well.

Thanks :)

Having the same error. Did you figure out what is going on by now?

Thank you

Hi @shar1, @woezon, and everyone!

The main thing is, you have to make sure that your submission file is shaped exactly as the sample submission, i.e. there must be only 2 columns, and the ID names have to match the submission file, as the system is comparing your submission with the testset based on the ID string. (But the IDs don't have to be in the same order.)

Here are common errors that people may be having.

1. When you export to a CSV, python and R sometimes automatically add a 1st column numbered 0, 1, 2..... Make sure you get rid of that column before submitting.

2. The ID has to match. For example some of you have used "*" instead of "x"

Hope this helps!